Audio Issues (Live Stream)
Incident Report for Lakeside Adventist Community
Resolved
Stream was finished
Posted Oct 17, 2020 - 12:17 AEDT
Update
We will continue to investigate the issue post service.
Posted Oct 17, 2020 - 11:39 AEDT
Investigating
We are currently investigating this issue.
Posted Oct 17, 2020 - 11:19 AEDT
This incident affected: Church Live Stream.